HomeWindLDR

Discussion for our PLC programming software.

Interfacing Issue of Idec (FC4A-d20) to Weintek Messages in this topic - RSS

salah Hayat
salah Hayat
Posts: 1

23 days ago
Respected Sir,
I request you for a solution of Weintek Hmi (MT8071iP) to Idec PLC (FC4A-D20) interfacing. Our existing system Idec Hmi (HG2F-SB22VF) to Idec Plc (FC4A-D20) .I want to replace Idec Hmi (HG2F-SB22VF) with Weintek Hmi (MT8071iP).So, I face interfacing issue of Weintek Hmi (MT8071ip) to Idec PLC (FC4A-D20).
Idec Hmi Setting
Baud Rate 9600 ,Data bit 7, Stop bit 1 , Parity Even, Serial Interface Rs232
Idec PLC Setting
Baud Rate 9600 ,Data bit 7, Stop bit 1 , Parity Even, Receive Timeout 500ms , Slave no 0.
Weintek Hmi Setting
Baud Rate 9600 , Data bit 7, Stop bit 1, Parity Even, COM COM1, Time out 1sec , Device defualt station 0, 1, 255.


Try with different baud rate ,device station, parity,data bit .
Please reply me as soon as possible.

Best Regards ,
Engr. Saleh Hayat
0 link
a062549
a062549
Posts: 35

23 days ago
I'd suggest changing the Station Number to something rather than "0". The Weinteks can be a bit quirky.

salah Hayat wrote:
Respected Sir,
I request you for a solution of Weintek Hmi (MT8071iP) to Idec PLC (FC4A-D20) interfacing. Our existing system Idec Hmi (HG2F-SB22VF) to Idec Plc (FC4A-D20) .I want to replace Idec Hmi (HG2F-SB22VF) with Weintek Hmi (MT8071iP).So, I face interfacing issue of Weintek Hmi (MT8071ip) to Idec PLC (FC4A-D20).
Idec Hmi Setting
Baud Rate 9600 ,Data bit 7, Stop bit 1 , Parity Even, Serial Interface Rs232
Idec PLC Setting
Baud Rate 9600 ,Data bit 7, Stop bit 1 , Parity Even, Receive Timeout 500ms , Slave no 0.
Weintek Hmi Setting
Baud Rate 9600 , Data bit 7, Stop bit 1, Parity Even, COM COM1, Time out 1sec , Device defualt station 0, 1, 255.


Try with different baud rate ,device station, parity,data bit .
Please reply me as soon as possible.

Best Regards ,
Engr. Saleh Hayat
0 link
Shane
Shane
Moderator
Posts: 334

20 days ago
I am unfamiliar with Weintek but what problem are you having? Any error messages? What protocol are you attempting to pull data from the PLC with? Modbus, direct, etc? If direct, does the Weintek have IDEC PLC drivers?
0 link




Powered by Jitbit Forum 8.2.0.0 © 2006-2013 Jitbit Software