HomeMicroSmart FC6A

A powerful micro PLC with the features of a PAC making it an ideal fit for demanding applications.

FC6A Ethernet Comms Issue Messages in this topic - RSS

Barry
Barry
Posts: 175

14 days ago
Hi there

I hope someone can offer a solution because this is a real PITA!

I have the following setup all over ethernet:

HG3G, fixed IP of 192.168.1.6
FC6A-C24R1CE fixed IP of 192.168.1.5
Laptop DHCP IP address of 192.168.1.100
Gateway 192.168.1.1

The HMI and PLC communicate no problem, I can download to the HMI using its IP address.

If I try to connect to the PLC over ethernet to 192.1681.5 WindLDR just times out and refuses to connect, I just get the dreaded spinning doughnut followed by "WindLDR failed to make a connection to the device with the IP address 192.168.1.5"

I've looked at everything I can think of, laptop firewall, etc but WindLDR refuses to connect to the PLC, I can connect to the PLC using USB no problem.

I'm at a loss, any suggestions?

Barry
0 link
Phillip
Phillip
Posts: 23

10 days ago
could be the version of WindLDR. I had a similar problem when the FC6A plus came out. I don't know which version it was, but it would connect once and then not connect about 5 times. Haven't had any issues with latest version. 8.12.0
0 link
Barry
Barry
Posts: 175

10 days ago
Hi Philip, yes, I'm on 8.12 also, but WindLDR won't connect to the PLC, strangely will connect to a C40 PLC but not C24 PLC?
0 link
Phillip
Phillip
Posts: 23

10 days ago
DOUBLE CHECK NETWORK NUMBERS. SOMETIMES I MAKE A MISTAKE ON ONE NUMBER AND HARD TO FIND IF NOT LOK FOR IT CLOSELY. YOU MIGHT TRY DOWNLOADING AN EMPTY PROGRAM WITH NEW NETWORK NUMBERS TO TRY.
0 link
Shane
Shane
Moderator
Posts: 273

10 days ago
Be sure you do not have "Use HGxG Pass-Through" selected on the communication settings or you'd have to send it using the HMI's IP address. Also be sure you have it set to the default port of 2101 unless you've changed it on purpose.
0 link
Barry
Barry
Posts: 175

2 days ago
Shane wrote:
Be sure you do not have &quotUse HGxG Pass-Through&quot selected on the communication settings or you'd have to send it using the HMI's IP address. Also be sure you have it set to the default port of 2101 unless you've changed it on purpose.
Hi Shane

Problem solved, it was the connection settings, I had only got one connection entry for Maintenance Communication Server. I fully populated the list for 8 connections and everything worked. I guess that it would have probably worked with just two entries but I haven't had time to try that yet.

Regards
Barry
edited by BarryH on 7/20/2019
0 link




Powered by Jitbit Forum 8.2.0.0 © 2006-2013 Jitbit Software